漏洞信息详情

CPP-Ethereum JSON-RPC 安全漏洞

  • CNNVD编号:CNNVD-201707-1637
  • 危害等级: 高危
  • CVE编号: CVE-2017-12116
  • 漏洞类型: 其他
  • 发布时间: 2017-07-31
  • 威胁类型: 远程
  • 更新时间: 2021-01-21
  • 厂        商: ethereum
  • 漏洞来源:

漏洞简介

CPP-Ethereum是Ethereum(应用程序运行平台)的C++客户端。JSON-RPC是其中的一个以JSON为协议的远程调用服务。

CPP-Ethereum commit 4e1015743b95821849d001618a7ce82c7c073768版本中的JSON-RPC的miner_setGasPrice API存在安全漏洞。攻击者可通过发送JSON请求利用该漏洞访问被限制的功能,绕过授权。

漏洞公告

目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

http://cpp-ethereum.org

参考网址

来源:MISC

链接:https://www.talosintelligence.com/vulnerability_reports/TALOS-2017-0468

来源:BID

链接:https://www.securityfocus.com/bid/102475

来源:MISC

链接:https://talosintelligence.com/vulnerability_reports/TALOS-2017-0468

受影响实体

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多