漏洞信息详情

strongSwan gmp插件安全漏洞

  • CNNVD编号:CNNVD-201707-518
  • 危害等级: 中危
  • CVE编号: CVE-2017-11185
  • 漏洞类型: 资料不足
  • 发布时间: 2017-07-13
  • 威胁类型: 远程
  • 更新时间: 2017-08-23
  • 厂        商: strongswan
  • 漏洞来源:

漏洞简介

strongSwan是瑞士软件开发者Andreas Steffen所维护的一套Linux平台使用的开源的基于IPsec的VPN解决方案。该方案包含X.509公开密钥证书、安全储存私钥、智能卡等认证机制。gmp plugin是其中的一个插件。

strongSwan 5.6.0之前的版本中的gmp插件存在安全漏洞。远程攻击者可借助特制的RSA签名利用该漏洞造成拒绝服务(空指针逆向引用和守护进程崩溃)。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://www.strongswan.org/blog/2017/08/14/strongswan-vulnerability-%28cve-2017-11185%29.html

参考网址

来源:CONFIRM

链接:https://www.strongswan.org/blog/2017/08/14/strongswan-vulnerability-(cve-2017-11185).html

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多