漏洞信息详情

libgig 安全漏洞

  • CNNVD编号:CNNVD-201708-822
  • 危害等级: 中危
  • CVE编号: CVE-2017-12951
  • 漏洞类型: 缓冲区错误
  • 发布时间: 2017-08-21
  • 威胁类型: 远程
  • 更新时间: 2019-10-23
  • 厂        商: libgig0
  • 漏洞来源:

漏洞简介

libgig是一个用于加载、修改和创建Gigasamlier和DLS文件的C++库。

libgig 4.0.0版本中的gig.cpp文件的‘gig::DimensionRegion::CreateVelocityTable’函数存在安全漏洞。远程攻击者可借助特制的gig文件利用该漏洞造成拒绝服务(基于栈的缓冲区越边界读取和应用程序崩溃)。

漏洞公告

目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://www.libgig.com/

参考网址

来源:FULLDISC

链接:http://seclists.org/fulldisclosure/2017/Aug/39

来源:EXPLOIT-DB

链接:https://www.exploit-db.com/exploits/42546/

受影响实体

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多