漏洞信息详情

i2pd和kovri 安全漏洞

  • CNNVD编号:CNNVD-201711-1153
  • 危害等级: 高危
  • CVE编号: CVE-2017-17066
  • 漏洞类型: 缓冲区错误
  • 发布时间: 2017-11-30
  • 威胁类型: 远程
  • 更新时间: 2019-10-23
  • 厂        商: getkovri
  • 漏洞来源:

漏洞简介

i2p是一个用于加密的网络协议,能够实现匿名访问互联网。i2pd是i2p客户端的C++实现。kovri是一个轻量级的兼容i2p的路由器。

i2pd 2.17之前的版本和kovri pre-alpha版本中存在安全漏洞,该漏洞源于程序没有正确的处理arlic DeliveryTypeTunnel数据包。远程攻击者可借助特制的数据包利用该漏洞从进程内存中获取敏感信息。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:

https://i2pd.readthedocs.io

参考网址

来源:MISC

链接:https://hackerone.com/reports/291489

来源:MISC

链接:https://eyalitkin.wordpress.com/2017/12/04/cve-publication-garlicrust-cve-2017-17066/

受影响实体

漏洞信息快速查询

相关漏洞

更多