漏洞信息详情

Swagger-Parser和swagger-codegen 安全漏洞

  • CNNVD编号:CNNVD-201711-764
  • 危害等级: 高危
  • CVE编号: CVE-2017-1000208
  • 漏洞类型: 代码问题
  • 发布时间: 2017-11-22
  • 威胁类型: 远程
  • 更新时间: 2019-10-23
  • 厂        商: swagger
  • 漏洞来源:

漏洞简介

Swagger-Parser是一个Swagger(跨语言REST API接口)解析器。swagger-codegen是一款API开发工具。

Swagger-Parser 1.0.30及之前的版本和swagger-codegen 2.2.2及之前的版本中存在安全漏洞。攻击者可利用该漏洞执行任意代码。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/swagger-api/swagger-parser/releases/tag/v1.0.31

参考网址

来源:MISC

链接:https://lgtm.com/blog/swagger_snakeyaml_CVE-2017-1000207_CVE-2017-1000208

来源:CONFIRM

链接:https://github.com/swagger-api/swagger-parser/releases/tag/v1.0.31

漏洞信息快速查询

相关漏洞

更多