漏洞信息详情

jQuery 跨站脚本漏洞

  • CNNVD编号:CNNVD-201801-798
  • 危害等级: 中危
  • CVE编号: CVE-2015-9251
  • 漏洞类型: 跨站脚本
  • 发布时间: 2018-01-22
  • 威胁类型: 远程
  • 更新时间: 2021-02-22
  • 厂        商: jquery
  • 漏洞来源: John Martinelli,Re...

漏洞简介

jQuery是美国John Resig程序员的一套开源、跨浏览器的JavaScript库。该库简化了HTML与JavaScript之间的操作,并具有模块化、插件扩展等特点。

jQuery 3.0.0之前版本中存在跨站脚本漏洞。该漏洞源于WEB应用缺少对客户端数据的正确验证。攻击者可利用该漏洞执行客户端代码。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:

https://jquery.com/

参考网址

来源:BID

链接:https://www.securityfocus.com/bid/105658

来源:REDHAT

链接:https://access.redhat.com/errata/RHSA-2020:0729

来源:MISC

链接:https://www.oracle.com/technetwork/security-advisory/cpuoct2019-5072832.html

来源:www.oracle.com

链接:https://www.oracle.com/technetwork/security-advisory/cpuoct2018-4428296.html

来源:www.oracle.com

链接:https://www.oracle.com/technetwork/security-advisory/cpujan2019-5072801.html

来源:www.oracle.com

链接:https://www.oracle.com/technetwork/security-advisory/cpuapr2019-5072813.html

来源:ics-cert.us-cert.gov

链接:https://ics-cert.us-cert.gov/advisories/ICSA-18-212-04

来源:sw.aveva.com

链接:https://sw.aveva.com/hubfs/assets-2018/pdf/security-bulletin/SecurityBulletin_LFSec126.pdf

来源:jquery.org

链接:https://jquery.org/

来源:github.com

链接:https://github.com/jquery/jquery/pull/2588

来源:github.com

链接:https://github.com/jquery/jquery/commit/f60729f3903d17917dc351f3ac87794de379b0cc

来源:BID

链接:http://www.securityfocus.com/bid/105658

来源:N/A

链接:https://www.oracle.com/security-alerts/cpuapr2020.html

来源:CONFIRM

链接:https://security.netapp.com/advisory/ntap-20210108-0004/

来源:MISC

链接:https://github.com/jquery/jquery/issues/2432

来源:MISC

链接:https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html

来源:MISC

链接:https://packetstormsecurity.com/files/156743/OctoberCMS-Insecure-Dependencies.html

来源:BUGTRAQ

链接:https://seclists.org/bugtraq/2019/May/18

来源:MISC

链接:https://packetstormsecurity.com/files/152787/dotCMS-5.1.1-Vulnerable-Dependencies.html

来源:MISC

链接:https://github.com/jquery/jquery/pull/2588/commits/c254d308a7d3f1eac4d0b42837804cfffcba4bb2

来源:MISC

链接:http://packetstormsecurity.com/files/152787/dotCMS-5.1.1-Vulnerable-Dependencies.html

来源:MISC

链接:https://www.oracle.com/security-alerts/cpuoct2020.html

来源:MISC

链接:http://packetstormsecurity.com/files/153237/RetireJS-CORS-Issue-Script-Execution.html

来源:REDHAT

链接:https://access.redhat.com/errata/RHSA-2020:0481

来源:FULLDISC

链接:http://seclists.org/fulldisclosure/2019/May/11

来源:FULLDISC

链接:http://seclists.org/fulldisclosure/2019/May/10

来源:MLIST

链接:https://lists.apache.org/thread.html/519eb0fd45642dcecd9ff74cb3e71c20a4753f7d82e2f07864b5108f@%3Cdev.drill.apache.org%3E

来源:MLIST

链接:https://lists.apache.org/thread.html/b0656d359c7d40ec9f39c8cc61bca66802ef9a2a12ee199f5b0c1442@%3Cdev.drill.apache.org%3E

来源:FULLDISC

链接:http://seclists.org/fulldisclosure/2019/May/13

来源:MISC

链接:https://packetstormsecurity.com/files/153237/RetireJS-CORS-Issue-Script-Execution.html

来源:MISC

链接:https://www.oracle.com/security-alerts/cpujan2020.html

来源:MLIST

链接:https://lists.apache.org/thread.html/54df3aeb4239b64b50b356f0ca6f986e3c4ca5b84c515dce077c7854@%3Cuser.flink.apache.org%3E

来源:CONFIRM

链接:https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA44601

来源:SUSE

链接:http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00041.html

来源:MLIST

链接:https://lists.apache.org/thread.html/f9bc3e55f4e28d1dcd1a69aae6d53e609a758e34d2869b4d798e13cc@%3Cissues.drill.apache.org%3E

来源:MISC

链接:https://snyk.io/vuln/npm:jquery:20150627

来源:MLIST

链接:https://lists.apache.org/thread.html/17ff53f7999e74fbe3cc0ceb4e1c3b00b180b7c5afec8e978837bc49@%3Cuser.flink.apache.org%3E

来源:MLIST

链接:https://lists.apache.org/thread.html/10f0f3aefd51444d1198c65f44ffdf2d78ca3359423dbc1c168c9731@%3Cdev.flink.apache.org%3E

来源:CONFIRM

链接:https://www.tenable.com/security/tns-2019-08

来源:CONFIRM

链接:http://www.oracle.com/technetwork/security-advisory/cpuoct2018-4428296.html

来源:MLIST

链接:https://lists.apache.org/thread.html/52bafac05ad174000ea465fe275fd3cc7bd5c25535a7631c0bc9bfb2@%3Cuser.flink.apache.org%3E

来源:MLIST

链接:https://lists.apache.org/thread.html/ba79cf1658741e9f146e4c59b50aee56656ea95d841d358d006c18b6@%3Ccommits.roller.apache.org%3E

来源:MISC

链接:https://www.oracle.com/security-alerts/cpujul2020.html

来源:www.ibm.com

链接:https://www.ibm.com/support/pages/node/1105515

来源:www.ibm.com

链接:https://www.ibm.com/support/pages/node/1105509

来源:www.ibm.com

链接:https://www.ibm.com/support/pages/node/1105479

来源:www.ibm.com

链接:https://www.ibm.com/support/pages/node/1106577

来源:access.redhat.com

链接:https://access.redhat.com/errata/RHSA-2020:0481

来源:www.ibm.com

链接:http://www.ibm.com/support/docview.wss?uid=ibm10874666

来源:fortiguard.com

链接:https://fortiguard.com/psirt/FG-IR-18-013

来源:www.ibm.com

链接:https://www.ibm.com/support/docview.wss?uid=ibm10967469

来源:www.oracle.com

链接:https://www.oracle.com/security-alerts/cpujul2020.html

来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/159353/Red-Hat-Security-Advisory-2020-3936-01.html

来源:www-01.ibm.com

链接:https://www-01.ibm.com/support/docview.wss?uid=ibm10878200

来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/156743/OctoberCMS-Insecure-Dependencies.html

来源:www.ibm.com

链接:https://www.ibm.com/blogs/psirt/security-bulletin-multiple-security-vulnerabilities-in-swagger-ui-affect-ibm-business-automation-workflow-and-ibm-business-process-manager-bpm/

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2019.4294/

来源:www.ibm.com

链接:https://www.ibm.com/blogs/psirt/security-bulletin-cross-site-scripting-and-vulnerable-library-jquery-v1-11-1-affects-ibm-engineering-workflow-management/

来源:www.ibm.com

链接:https://www.ibm.com/blogs/psirt/security-bulletin-multiple-security-vulnerabilities-in-swagger-ui-affect-ibm-business-automation-workflow-and-ibm-business-process-manager-bpm-2/

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2021.0465

来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/156630/Red-Hat-Security-Advisory-2020-0729-01.html

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/78866

来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/152787/dotCMS-5.1.1-Vulnerable-Dependencies.html

来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/156941/Red-Hat-Security-Advisory-2020-0983-01.html

来源:www.ibm.com

链接:https://www.ibm.com/support/pages/node/1105497

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2020.3875/

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2020.1016/

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2020.3902/

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2020.0832/

来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/159852/Red-Hat-Security-Advisory-2020-4847-01.html

来源:www-01.ibm.com

链接:http://www-01.ibm.com/support/docview.wss?uid=ibm10874666

来源:www.ibm.com

链接:https://www.ibm.com/blogs/psirt/security-bulletin-ibm-security-qradar-analyst-workflow-add-on-to-ibm-qradar-siem-is-vulnerable-to-using-components-with-known-vulnerabilities-2/

来源:www.ibm.com

链接:https://www.ibm.com/blogs/psirt/security-bulletin-multiple-vulnerability-issues-affect-ibm-spectrum-symphony-7-3-1/

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/79122

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2020.0494/

来源:www.securityfocus.com

链接:https://www.securityfocus.com/bid/105658

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/78794

来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/156315/Red-Hat-Security-Advisory-2020-0481-01.html

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2020.3267/

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2020.1076/

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2020.3368/

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2019.3165/

漏洞信息快速查询

相关漏洞

更多