漏洞信息详情

GNU libcdio 缓冲区错误漏洞

  • CNNVD编号:CNNVD-201802-631
  • 危害等级: 高危
  • CVE编号: CVE-2017-18198
  • 漏洞类型: 缓冲区错误
  • 发布时间: 2018-02-26
  • 威胁类型: 远程
  • 更新时间: 2018-02-26
  • 厂        商: gnu
  • 漏洞来源:

漏洞简介

GNU libcdio是一个光盘输入和控制库,其中包含了用于访问CD-ROM和CD镜像的函数库。

GNU libcdio 1.0.0之前版本中的iso-info.c文件的‘print_iso9660_recurse’函数存在堆缓冲区溢出漏洞。远程攻击者可借助特制的iso文件利用该漏洞造成拒绝服务(基于堆的缓冲区越边界读取)。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://savannah.gnu.org/bugs/?52264

参考网址

来源:CONFIRM

链接:http://ftp.gnu.org/gnu/libcdio/libcdio-1.0.0.tar.gz

来源:CONFIRM

链接:https://savannah.gnu.org/bugs/?52265

受影响实体

漏洞信息快速查询

相关漏洞

更多