漏洞信息详情

strongSwan 安全漏洞

  • CNNVD编号:CNNVD-201802-789
  • 危害等级: 中危
  • CVE编号: CVE-2018-6459
  • 漏洞类型: 数据伪造问题
  • 发布时间: 2018-02-20
  • 威胁类型: 远程
  • 更新时间: 2020-03-31
  • 厂        商: strongswan
  • 漏洞来源:

漏洞简介

strongSwan是瑞士软件开发者Andreas Steffen所维护的一套Linux平台使用的开源的基于IPsec的VPN解决方案。该方案包含X.509公开密钥证书、安全储存私钥、智能卡等认证机制。

strongSwan 5.6.1版本中的libstrongswan/credentials/keys/signature_params.c文件的‘rsa_pss_params_parse’函数存在安全漏洞。远程攻击者可借助特制的RSASSA-PSS签名利用该漏洞造成拒绝服务。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://www.strongswan.org/blog/2018/02/19/strongswan-vulnerability-%28cve-2018-6459%29.html

参考网址

来源:GENTOO

链接:https://security.gentoo.org/glsa/201811-16

来源:SUSE

链接:http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00047.html

来源:CONFIRM

链接:https://www.strongswan.org/blog/2018/02/19/strongswan-vulnerability-(cve-2018-6459).html

来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/strongSwan-denial-of-service-via-rsa-pss-params-parse-31866

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2020.1036/

漏洞信息快速查询

相关漏洞

更多