漏洞信息详情

KTextEditor 安全漏洞

  • CNNVD编号:CNNVD-201804-1460
  • 危害等级: 高危
  • CVE编号: CVE-2018-10361
  • 漏洞类型: 权限许可和访问控制问题
  • 发布时间: 2018-04-26
  • 威胁类型: 本地
  • 更新时间: 2019-10-08
  • 厂        商:
  • 漏洞来源:

漏洞简介

KTextEditor是一款KDE Frameworks中的提供高级纯文本编辑功能的编辑器。

KTextEditor 5.34.0版本至5.45.0版本中存在安全漏洞,该漏洞源于KTextEditor的kauth_ktexteditor_helper服务没有正确的处理临时文件。攻击者可通过向其他非特权用户所有的目录写入文本文件并通过其他用户实施符号链接攻击利用该漏洞获取root权限。

漏洞公告

目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://api.kde.org/frameworks/ktexteditor/html/index.html

参考网址

来源:MLIST

链接:http://www.openwall.com/lists/oss-security/2019/07/09/3

来源:MISC

链接:https://bugzilla.suse.com/show_bug.cgi?id=1033055

来源:MISC

链接:http://www.openwall.com/lists/oss-security/2018/04/24/1

受影响实体

    暂无


补丁

    暂无

漏洞信息快速查询

相关漏洞

更多