漏洞信息详情

PHP 输入验证漏洞

  • CNNVD编号:CNNVD-201805-054
  • 危害等级: 中危
  • CVE编号: CVE-2018-10547
  • 漏洞类型: 跨站脚本
  • 发布时间: 2018-04-29
  • 威胁类型: 远程
  • 更新时间: 2019-08-20
  • 厂        商: debian
  • 漏洞来源: Red Hat

漏洞简介

PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHP Group和开放源代码社区共同维护的一种开源的通用计算机脚本语言。该语言主要用于Web开发,支持多种数据库及操作系统。

PHP中的PHAR 404和PHAR 403错误页面存在输入验证漏洞,该漏洞源于程序没有过滤用户的输入。远程攻击者可利用该漏洞进行劫持用户浏览器会话、植入传播恶意代码等网络攻击,可能会造成用户账号被盗取、用户隐私泄露等危害。以下版本受到影响:PHP 5.6.36之前的版本,7.0.27之前的7.0.x版本,7.1.13之前的7.1.x版本,7.2.1之前的7.2.x版本。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

http://php.net/ChangeLog-5.php

http://php.net/ChangeLog-7.php

参考网址

来源:SECTRACK

链接:http://www.securitytracker.com/id/1040807

来源:DEBIAN

链接:https://www.debian.org/security/2018/dsa-4240

来源:MLIST

链接:https://lists.debian.org/debian-lts-announce/2018/05/msg00004.html

来源:MLIST

链接:https://lists.debian.org/debian-lts-announce/2018/06/msg00005.html

来源:CONFIRM

链接:https://bugs.php.net/bug.php?id=76129

来源:CONFIRM

链接:http://php.net/ChangeLog-7.php

来源:CONFIRM

链接:https://security.netapp.com/advisory/ntap-20180607-0003/

来源:UBUNTU

链接:https://usn.ubuntu.com/3646-2/

来源:UBUNTU

链接:https://usn.ubuntu.com/3646-1/

来源:CONFIRM

链接:https://www.tenable.com/security/tns-2018-12

来源:CONFIRM

链接:http://php.net/ChangeLog-5.php

来源:access.redhat.com

链接:https://access.redhat.com/errata/RHSA-2019:2519

来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/154136/Red-Hat-Security-Advisory-2019-2519-01.html

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2019.3172/

受影响实体

漏洞信息快速查询

相关漏洞

更多