漏洞信息详情

ImageMagick 缓冲区错误漏洞

漏洞简介

ImageMagick是美国ImageMagick Studio公司的一套开源的图象处理软件。该软件可读取、转换、写入多种格式的图片。

ImageMagick 7.0.7-37 Q16版本中的quantize.c文件的SetGrayscaleImage存在堆缓冲区溢出漏洞。攻击者可借助特制的文件利用该漏洞造成基于堆的缓冲区越界读取。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/ImageMagick/ImageMagick/issues/1156

参考网址

来源:UBUNTU

链接:https://usn.ubuntu.com/3681-1/

来源:MISC

链接:https://github.com/ImageMagick/ImageMagick/issues/1156

漏洞信息快速查询

相关漏洞

更多