漏洞信息详情

LibSass 缓冲区错误漏洞

  • CNNVD编号:CNNVD-201806-283
  • 危害等级: 高危
  • CVE编号: CVE-2018-11693
  • 漏洞类型: 缓冲区错误
  • 发布时间: 2018-06-05
  • 威胁类型: 远程
  • 更新时间: 2019-04-04
  • 厂        商: sass-lang
  • 漏洞来源:

漏洞简介

LibSass是一个开源的使用C语言编写的Sass(CSS扩展语言)解析器。

LibSass 3.5.4及之前版本中的‘Sass::Prelexer::skip_over_scopes’函数存在缓冲区溢出漏洞,该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

http://libsass.org/

参考网址

来源:MISC

链接:https://github.com/sass/libsass/issues/2661

来源:www.ibm.com

链接:http://www.ibm.com/support/docview.wss

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/78350

来源:www.ibm.com

链接:http://www.ibm.com/support/docview.wss?uid=ibm10794165

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多