漏洞信息详情

Liblouis 缓冲区错误漏洞

  • CNNVD编号:CNNVD-201806-286
  • 危害等级: 高危
  • CVE编号: CVE-2018-11684
  • 漏洞类型: 缓冲区错误
  • 发布时间: 2018-06-05
  • 威胁类型: 远程
  • 更新时间: 2020-08-25
  • 厂        商: liblouis
  • 漏洞来源: Red Hat

漏洞简介

Liblouis是一款使用C语言编写的开源的盲文翻译器。

Liblouis 3.5.0版本中的compileTranslationTable.c文件的‘includeFile’函数存在基于栈的缓冲区溢出漏洞。攻击者可利用该漏洞执行任意代码或造成拒绝服务。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/liblouis/liblouis/issues/592

参考网址

来源:SUSE

链接:http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00038.html

来源:MISC

链接:https://github.com/liblouis/liblouis/issues/592

来源:UBUNTU

链接:https://usn.ubuntu.com/3672-1/

来源:www.suse.com

链接:https://www.suse.com/support/update/announcement/2019/suse-su-20190795-1.html

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/78022

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2020.1517/

来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/157456/Red-Hat-Security-Advisory-2020-1708-01.html

受影响实体

漏洞信息快速查询

相关漏洞

更多