漏洞信息详情

Sensio Labs Twig 安全漏洞

  • CNNVD编号:CNNVD-201807-959
  • 危害等级: 超危
  • CVE编号: CVE-2018-13818
  • 漏洞类型: 代码注入
  • 发布时间: 2018-07-10
  • 威胁类型: 远程
  • 更新时间: 2019-03-13
  • 厂        商: symfony
  • 漏洞来源:

漏洞简介

Sensio Labs Twig是法国Sensio Labs公司的一个PHP模板引擎,它允许开发人员自定义标签和过滤器,并创建DSL。

Sensio Labs Twig 2.4.4之前版本中存在安全漏洞。攻击者可借助‘search search_key’参数利用该漏洞执行命令。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/twigphp/Twig/blob/2.x/CHANGELOG

参考网址

来源:MISC

链接:https://github.com/twigphp/Twig/blob/2.x/CHANGELOG

来源:EXPLOIT-DB

链接:https://www.exploit-db.com/exploits/44102/

来源:MISC

链接:https://github.com/twigphp/Twig/commit/eddb97148ad779f27e670e1e3f19fb323aedafeb

来源:MISC

链接:https://github.com/twigphp/Twig/issues/2743

来源:MISC

链接:https://mobile.twitter.com/jameel_nabbo/status/1032593354704515072?s=20

漏洞信息快速查询

相关漏洞

更多