漏洞信息详情

PHP 缓冲区错误漏洞

  • CNNVD编号:CNNVD-201808-156
  • 危害等级: 高危
  • CVE编号: CVE-2018-14883
  • 漏洞类型: 缓冲区错误
  • 发布时间: 2018-08-06
  • 威胁类型: 远程
  • 更新时间: 2020-09-24
  • 厂        商: php
  • 漏洞来源:

漏洞简介

PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHPGroup和开放源代码社区的共同维护的一种开源的通用计算机脚本语言。该语言主要用于Web开发,支持多种数据库及操作系统。

PHP 中存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。以下产品及版本受到影响: PHP 5.6.37之前版本, 7.0.x系列7.0.31之前版本, 7.1.x 系列7.1.20之前版本, 7.2.x系列7.2.8之前版本。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

http://php.net/ChangeLog-5.php

http://php.net/ChangeLog-7.php

参考网址

来源:CONFIRM

链接:https://bugs.php.net/bug.php?id=76423

来源:DEBIAN

链接:https://www.debian.org/security/2018/dsa-4353

来源:BID

链接:https://www.securityfocus.com/bid/104871

来源:BID

链接:http://www.securityfocus.com/bid/104871

来源:CONFIRM

链接:https://security.netapp.com/advisory/ntap-20181107-0003/

来源:CONFIRM

链接:http://php.net/ChangeLog-7.php

来源:UBUNTU

链接:https://usn.ubuntu.com/3766-1/

来源:CONFIRM

链接:https://www.tenable.com/security/tns-2018-12

来源:CONFIRM

链接:http://php.net/ChangeLog-5.php

来源:MLIST

链接:https://lists.debian.org/debian-lts-announce/2018/09/msg00000.html

来源:UBUNTU

链接:https://usn.ubuntu.com/3766-2/

来源:www.ibm.com

链接:http://www.ibm.com/support/docview.wss

来源:www.ibm.com

链接:http://www.ibm.com/support/docview.wss?uid=ibm10870684

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/77974

漏洞信息快速查询

相关漏洞

更多