漏洞信息详情

xkbcommon 安全漏洞

  • CNNVD编号:CNNVD-201808-793
  • 危害等级: 中危
  • CVE编号: CVE-2018-15862
  • 漏洞类型: 代码问题
  • 发布时间: 2018-08-27
  • 威胁类型: 本地
  • 更新时间: 2019-08-08
  • 厂        商: canonical
  • 漏洞来源:

漏洞简介

xkbcommon是一个键盘键映射编译器和支持库。

xkbcommon 0.8.2之前版本中的xkbcomp/expr.c文件的‘LookupModMask’函数存在安全漏洞。本地攻击者可通过提交含有无效virtual修饰符的特制的keymap文件利用该漏洞造成xkbcommon解析器崩溃(空指针逆向引用)。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/xkbcommon/libxkbcommon/commit/4e2ee9c3f6050d773f8bbe05bc0edb17f1ff8371

参考网址

来源:GENTOO

链接:https://security.gentoo.org/glsa/201810-05

来源:MISC

链接:https://lists.freedesktop.org/archives/wayland-devel/2018-August/039243.html

来源:MISC

链接:https://github.com/xkbcommon/libxkbcommon/commit/4e2ee9c3f6050d773f8bbe05bc0edb17f1ff8371

来源:REDHAT

链接:https://access.redhat.com/errata/RHSA-2019:2079

来源:UBUNTU

链接:https://usn.ubuntu.com/3786-2/

来源:UBUNTU

链接:https://usn.ubuntu.com/3786-1/

来源:access.redhat.com

链接:https://access.redhat.com/errata/RHSA-2019:2079

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2019.2971/

漏洞信息快速查询

相关漏洞

更多