漏洞信息详情

okular 路径遍历漏洞

  • CNNVD编号:CNNVD-201809-309
  • 危害等级: 中危
  • CVE编号: CVE-2018-1000801
  • 漏洞类型: 路径遍历
  • 发布时间: 2018-09-07
  • 威胁类型: 本地
  • 更新时间: 2019-03-21
  • 厂        商: kde
  • 漏洞来源:

漏洞简介

okular是KDE社区开发的一款通用文档查看器,它支持查看PDF、Postscript、DjVu和CHM等格式文档。

okular 18.08及之前版本中的core/document.cpp文件的‘unpackDocumentArchive(...)’函数存在目录遍历漏洞。攻击者可借助特制的Okular归档文件利用该漏洞在用户工作站上创建任意文件。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://bugs.kde.org/show_bug.cgi?id=398096

参考网址

来源:MLIST

链接:https://lists.debian.org/debian-lts-announce/2018/09/msg00027.html

来源:CONFIRM

链接:https://cgit.kde.org/okular.git/commit/?id=8ff7abc14d41906ad978b6bc67e69693863b9d47

来源:GENTOO

链接:https://security.gentoo.org/glsa/201811-08

来源:CONFIRM

链接:https://bugs.kde.org/show_bug.cgi?id=398096

来源:DEBIAN

链接:https://www.debian.org/security/2018/dsa-4303

受影响实体

漏洞信息快速查询

相关漏洞

更多