漏洞信息详情

pdfalto 缓冲区错误漏洞

  • CNNVD编号:CNNVD-201810-677
  • 危害等级: 中危
  • CVE编号: CVE-2018-18274
  • 漏洞类型: 缓冲区溢出
  • 发布时间: 2018-10-15
  • 威胁类型: 远程
  • 更新时间: 2018-10-15
  • 厂        商: Pdfalto_project
  • 漏洞来源:

漏洞简介

Pdfalto是一款用于解析PDF文件并以ALTO格式生成XML结构化内容的命令行工具。

Pdfalto 0.2版本中的XmlAltoOutputDev.cc文件的‘TextPage::addAttributsNode’函数存在基于堆的缓冲区溢出漏洞。攻击者可利用该漏洞执行任意代码或造成拒绝服务。

漏洞公告

目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://github.com/kermitt2/pdfalto

参考网址

来源:github.com

链接:https://github.com/kermitt2/pdfalto/issues/33

来源:github.com

链接:https://github.com/TeamSeri0us/pocs/tree/master/pdfalto

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多