漏洞信息详情

PHP 安全漏洞

  • CNNVD编号:CNNVD-201811-619
  • 危害等级: 中危
  • CVE编号: CVE-2018-19395
  • 漏洞类型: 资料不足
  • 发布时间: 2018-11-21
  • 威胁类型: 远程
  • 更新时间: 2018-11-21
  • 厂        商: php
  • 漏洞来源:

漏洞简介

PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHP Group和开放源代码社区共同维护的一种开源的通用计算机脚本语言。该语言主要用于Web开发,支持多种数据库及操作系统。

基于Windows平台的PHP 5.x版本至7.1.24版本中的ext/standard/var.c文件存在安全漏洞,该漏洞源于在ext/com_dotnet/com_handlers.c文件的com_properties_get中,com和com_safearray_proxy的返回值总为空。攻击者可利用该漏洞造成拒绝服务(空指针逆向引用和应用程序崩溃)。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://bugs.php.net/bug.php?id=77177

参考网址

来源:bugs.php.net

链接:https://bugs.php.net/bug.php?id=77177

漏洞信息快速查询

相关漏洞

更多