漏洞信息详情

libsndfile 缓冲区错误漏洞

  • CNNVD编号:CNNVD-201811-912
  • 危害等级: 高危
  • CVE编号: CVE-2018-19662
  • 漏洞类型: 缓冲区错误
  • 发布时间: 2018-11-30
  • 威胁类型: 远程
  • 更新时间: 2020-04-30
  • 厂        商: libsndfile_project
  • 漏洞来源: Red Hat

漏洞简介

libsndfile是软件开发者Erik de Castro Lopo所研发的一个通过标准接口读写AIFF、AU和WAV等格式的音频文件的C库。

libsndfile 1.0.28版本中的alaw.c文件的‘i2alaw_array’函数存在缓冲区越界读取漏洞。攻击者可利用该漏洞造成拒绝服务。

漏洞公告

目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://github.com/erikd/libsndfile

参考网址

来源:MISC

链接:https://github.com/erikd/libsndfile/issues/429

来源:MLIST

链接:https://lists.debian.org/debian-lts-announce/2018/12/msg00016.html

来源:usn.ubuntu.com

链接:https://usn.ubuntu.com/4013-1/

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2019.2063/

来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/157457/Red-Hat-Security-Advisory-2020-1636-01.html

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2020.1498/

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多