漏洞信息详情

lxml 安全漏洞

  • CNNVD编号:CNNVD-201812-001
  • 危害等级: 中危
  • CVE编号: CVE-2018-19787
  • 漏洞类型: 跨站脚本
  • 发布时间: 2018-12-03
  • 威胁类型: 远程
  • 更新时间: 2018-12-03
  • 厂        商: lxml
  • 漏洞来源:

漏洞简介

lxml是一个使用Python语言编写的用于处理XML和HTML的库。lxml.html.clean module是其中的一个HTML清理模块。

lxml 4.2.5之前版本中存在安全漏洞,该漏洞源于lxml.html.clean模块的lxml/html/clean.py文件没有移除使用转义的javascript: URLs。远程攻击者可利用该漏洞实施跨站脚本攻击。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/lxml/lxml/commit/6be1d081b49c97cfd7b3fbd934a193b668629109

参考网址

来源:github.com

链接:https://github.com/lxml/lxml/commit/6be1d081b49c97cfd7b3fbd934a193b668629109

漏洞信息快速查询

相关漏洞

更多