漏洞信息详情

PHP-Proxy 加密问题漏洞

  • CNNVD编号:CNNVD-201812-003
  • 危害等级: 高危
  • CVE编号: CVE-2018-19784
  • 漏洞类型: 加密问题
  • 发布时间: 2018-12-03
  • 威胁类型: 远程
  • 更新时间: 2019-10-23
  • 厂        商: php-proxy
  • 漏洞来源:

漏洞简介

PHP-Proxy是一款基于PHP的代理程序。

PHP-Proxy 5.1.0及之前版本中的vendor/atholn1600/php-proxy/src/helpers.php文件的‘str_rot_pass’函数存在安全漏洞。远程攻击者可利用该漏洞获取密码文件。

漏洞公告

目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://www.php-proxy.com/

参考网址

来源:MISC

链接:https://github.com/eddietcc/CVE-Bins/blob/master/PHP-Proxy/readme.md

来源:MISC

链接:https://github.com/Athlon1600/php-proxy-app/issues/139

受影响实体

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多