漏洞信息详情

VideoLAN VLC media player 缓冲区错误漏洞

  • CNNVD编号:CNNVD-201812-190
  • 危害等级: 超危
  • CVE编号: CVE-2018-19857
  • 漏洞类型: 缓冲区错误
  • 发布时间: 2018-12-06
  • 威胁类型: 远程
  • 更新时间: 2019-07-29
  • 厂        商: Videolan
  • 漏洞来源: Ubuntu

漏洞简介

VideoLAN VLC media player是法国VideoLAN组织的一款免费、开源的跨平台多媒体播放器(也是一个多媒体框架)。该产品支持播放多种介质(文件、光盘等)、多种音视频格式(WMV,MP3等)等。

VideoLAN VLC media player 3.0.4版本中的modules/demux/caf.c文件的CAF demuxer存在缓冲区错误漏洞,该漏洞源于‘ReadKukiChunk()’函数将返回值强制转换为无符号的整型,即便该返回值为负。攻击者可利用该漏洞造成拒绝服务和信息泄露。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://git.videolan.org/?p=vlc.git;a=commit;h=0cc5ea748ee5ff7705dde61ab15dff8f58be39d0

参考网址

来源:MISC

链接:https://dyntopia.com/advisories/013-vlc

来源:MISC

链接:https://git.videolan.org/?p=vlc.git;a=commit;h=0cc5ea748ee5ff7705dde61ab15dff8f58be39d0

来源:DEBIAN

链接:https://www.debian.org/security/2019/dsa-4366

来源:BID

链接:http://www.securityfocus.com/bid/106130

来源:BID

链接:https://www.securityfocus.com/bid/106130

来源:UBUNTU

链接:https://usn.ubuntu.com/4074-1/

来源:usn.ubuntu.com

链接:https://usn.ubuntu.com/4074-1/

来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/153762/Ubuntu-Security-Notice-USN-4074-1.html

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2019.2802/

漏洞信息快速查询

相关漏洞

更多