漏洞信息详情

PHP 安全漏洞

  • CNNVD编号:CNNVD-201812-293
  • 危害等级: 高危
  • CVE编号: CVE-2018-19935
  • 漏洞类型: 代码问题
  • 发布时间: 2018-12-10
  • 威胁类型: 远程
  • 更新时间: 2019-06-19
  • 厂        商: php
  • 漏洞来源:

漏洞简介

PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHP Group和开放源代码社区共同维护的一种开源的通用计算机脚本语言。该语言主要用于Web开发,支持多种数据库及操作系统。

PHP 5.x版本和7.3.0之前的7.x版本中的ext/imap/php_imap.c文件存在安全漏洞。远程攻击者可借助‘message’参数中的空字符串利用该漏洞造成拒绝服务(空指针逆向引用和应用程序崩溃)。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://bugs.php.net/bug.php?id=77020

参考网址

来源:SUSE

链接:http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00041.html

来源:CONFIRM

链接:https://security.netapp.com/advisory/ntap-20181221-0003/

来源:SUSE

链接:http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00044.html

来源:BID

链接:https://www.securityfocus.com/bid/106143

来源:DEBIAN

链接:https://www.debian.org/security/2018/dsa-4353

来源:MLIST

链接:https://lists.debian.org/debian-lts-announce/2018/12/msg00006.html

来源:MISC

链接:https://bugs.php.net/bug.php?id=77020

来源:https://www.suse.com/support/update/announcement/2019/suse-su-20190333-1/

链接:无

来源:www.suse.com

链接:https://www.suse.com/support/update/announcement/2019/suse-su-20191461-1.html

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/75514

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2019.2087/

漏洞信息快速查询

相关漏洞

更多