漏洞信息详情

libmysofa 输入验证错误漏洞

  • CNNVD编号:CNNVD-201903-1230
  • 危害等级: 超危
  • CVE编号: CVE-2019-10672
  • 漏洞类型: 输入验证错误
  • 发布时间: 2019-03-31
  • 威胁类型: 远程
  • 更新时间: 2019-07-25
  • 厂        商:
  • 漏洞来源: Ubuntu

漏洞简介

libmysofa是一款用于读取AES SOFA文件的库。

libmysofa 0.7之前版本中的hdf/btree.c文件的treeRead存在输入验证错误漏洞。该漏洞源于网络系统或产品未对输入的数据进行正确的验证。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/hoene/libmysofa/releases/tag/v0.7

参考网址

来源:github.com

链接:https://github.com/hoene/libmysofa/releases/tag/v0.7

来源:github.com

链接:https://github.com/hoene/libmysofa/compare/49aa1c7...2ed84bb

来源:github.com

链接:https://github.com/hoene/libmysofa/commit/d39a171e9c6a1c44dbdf43f9db6c3fbd887e38c1

来源:usn.ubuntu.com

链接:https://usn.ubuntu.com/4033-1/

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-10672

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2019.2272/

来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/libmysofa-denial-of-service-via-Multiplications-Additions-29613

来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/153423/Ubuntu-Security-Notice-USN-4033-1.html

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多