漏洞信息详情

PHP 缓冲区错误漏洞

漏洞简介

PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHPGroup和开放源代码社区的共同维护的一种开源的通用计算机脚本语言。该语言主要用于Web开发,支持多种数据库及操作系统。EXIF component是其中的一个可交换图像文件格式处理组件。

PHP 7.1.27之前版本、7.2.16之前的7.2.x版本和7.3.3之前的7.3.x版本中的EXIF组件的‘exif_process_IFD_in_TIFF’函数存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://bugs.php.net/bug.php?id=77509

参考网址

来源:SUSE

链接:http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00041.html

来源:CONFIRM

链接:https://security.netapp.com/advisory/ntap-20190502-0007/

来源:DEBIAN

链接:https://www.debian.org/security/2019/dsa-4403

来源:SUSE

链接:http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00044.html

来源:MISC

链接:https://bugs.php.net/bug.php?id=77509

来源:UBUNTU

链接:https://usn.ubuntu.com/3922-3/

来源:SUSE

链接:http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00104.html

来源:UBUNTU

链接:https://usn.ubuntu.com/3922-1/

来源:UBUNTU

链接:https://usn.ubuntu.com/3922-2/

来源:SUSE

链接:http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00083.html

来源:MLIST

链接:https://lists.debian.org/debian-lts-announce/2019/03/msg00043.html

来源:www.debian.org

链接:http://www.debian.org/security/2019/dsa-4403

来源:lists.debian.org

链接:https://lists.debian.org/debian-lts-announce/2019/03/msg00043.html

来源:www.suse.com

链接:https://www.suse.com/support/update/announcement/2019/suse-su-20190985-1.html

来源:usn.ubuntu.com

链接:https://usn.ubuntu.com/3922-1/

来源:www.ibm.com

链接:http://www.ibm.com/support/docview.wss

来源:www-01.ibm.com

链接:https://www-01.ibm.com/support/docview.wss?uid=ibm10879401

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/78550

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/79498

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-9641

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/76794

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/78126

来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/152243/Ubuntu-Security-Notice-USN-3922-1.html

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/77854

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多