漏洞信息详情

CakePHP SmtpTransport 输入验证错误漏洞

  • CNNVD编号:CNNVD-201905-209
  • 危害等级: 高危
  • CVE编号: CVE-2019-11458
  • 漏洞类型: 输入验证错误
  • 发布时间: 2019-05-08
  • 威胁类型: 远程
  • 更新时间: 2019-05-14
  • 厂        商:
  • 漏洞来源:

漏洞简介

CakePHP是美国Cake软件基金会的一款基于MVC架构的、开源的Web开发框架。该框架具有灵活的视图缓存、自动生成CRUD代码等功能。SmtpTransport是其中的一个消息传输组件。

CakePHP 3.7.6版本中的SmtpTransport存在安全漏洞。攻击者可利用该漏洞覆盖任意文件。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://bakery.cakephp.org/2019/04/23/cakephp_377_3615_3518_released.html

参考网址

来源:github.com

链接:https://github.com/cakephp/cakephp/releases

来源:github.com

链接:https://github.com/cakephp/cakephp/compare/3.7.6...3.7.7

来源:github.com

链接:https://github.com/cakephp/cakephp/commits/master

来源:github.com

链接:https://github.com/cakephp/cakephp/commit/1a74e798309192a9895c9cedabd714ceee345f4e

来源:bakery.cakephp.org

链接:https://bakery.cakephp.org/2019/04/23/cakephp_377_3615_3518_released.html

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-11458

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多