漏洞信息详情

NGINX njs 缓冲区错误漏洞

漏洞简介

NGINX是美国NGINX公司的一款轻量级Web服务器/反向代理服务器及电子邮件(IMAP/POP3)代理服务器。njs是其中的一个支持扩展NGINX功能的脚本语言组件。

NGINX中使用的njs 0.3.1及之前版本的nxt_utf8.c文件的‘nxt_utf8_encode’函数存在基于堆的缓冲区溢出漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://nginx.org/

参考网址

来源:github.com

链接:https://github.com/nginx/njs/issues/162

来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/nginx-buffer-overflow-via-njs-29368

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-12206

受影响实体

    暂无


补丁

    暂无

漏洞信息快速查询

相关漏洞

更多