漏洞信息详情

radare2 缓冲区错误漏洞

漏洞简介

radare2是一套用于处理二进制文件的库和工具。

radare2 3.5.1及之前版本中存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/radare/radare2/issues/14303

参考网址

来源:github.com

链接:https://github.com/radare/radare2/issues/14303

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-12829

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多