漏洞信息详情

RDK CcspPandM模块缓冲区错误漏洞

  • CNNVD编号:CNNVD-201906-821
  • 危害等级: 中危
  • CVE编号: CVE-2019-6964
  • 漏洞类型: 缓冲区错误
  • 发布时间: 2019-06-20
  • 威胁类型:
  • 更新时间: 2019-06-21
  • 厂        商:
  • 漏洞来源:

漏洞简介

RDK是RDK Management社区的一套模块化、可移植、可定制的开源物联网软件解决方案。CcspPandM是其中的一个用于实现设备的核心配置和管理功能的模块。

RDK RDKB-20181217-1版本中的CcspPandM模块的cosa_x_cisco_com_ddns_dml.c文件的‘Service_SetParamStringValue’函数存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:

https://rdkcentral.com/

参考网址

来源:dojo.bullguard.com

链接:https://dojo.bullguard.com/dojo-by-bullguard/blog/the-gateway-is-wide-open

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-6964

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多