漏洞信息详情

EthereumJ 代码问题漏洞

  • CNNVD编号:CNNVD-201906-830
  • 危害等级: 超危
  • CVE编号: CVE-2018-15890
  • 漏洞类型: 代码问题
  • 发布时间: 2019-06-20
  • 威胁类型: 远程
  • 更新时间: 2019-06-21
  • 厂        商: Ethereum
  • 漏洞来源:

漏洞简介

EthereumJ是一款以太坊协议的Java语言实现。

EthereumJ 1.8.2版本中的crypto/ECKey.java文件的decoder.readObject和mine/Ethash.java文件的ois.readObject存在代码问题漏洞。攻击者可利用该漏洞执行任意的操作系统命令。

漏洞公告

目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://github.com/ethereum/ethereumj

参考网址

来源:github.com

链接:https://github.com/frohoff/ysoserial/

来源:github.com

链接:https://github.com/ethereum/ethereumj/issues/1161

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2018-15890

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多