漏洞信息详情

WordPress wp-code-highlightjs插件跨站请求伪造漏洞

  • CNNVD编号:CNNVD-201907-1145
  • 危害等级: 高危
  • CVE编号: CVE-2019-12934
  • 漏洞类型: 跨站请求伪造
  • 发布时间: 2019-07-19
  • 威胁类型: 远程
  • 更新时间: 2019-08-15
  • 厂        商:
  • 漏洞来源: ZeroAuth

漏洞简介

WordPress是WordPress基金会的一套使用PHP语言开发的博客平台。该平台支持在PHP和MySQL的服务器上架设个人博客网站。wp-code-highlightjs plugin是使用在其中的一个高亮显示插件。

WordPress wp-code-highlightjs插件0.6.2及之前版本中存在跨站请求伪造漏洞。该漏洞源于WEB应用未充分验证请求是否来自可信用户。攻击者可利用该漏洞通过受影响客户端向服务器发送非预期的请求。

漏洞公告

目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://wordpress.org/plugins/wp-code-highlightjs/

参考网址

来源:zeroauth.ltd

链接:https://zeroauth.ltd/blog/2019/07/17/cve-2019-12934-wp-code-highlightjs-wordpress-plugin-csrf-leads-to-blog-wide-injected-script-html/

来源:wordpress.org

链接:https://wordpress.org/plugins/wp-code-highlightjs/#developers

来源:github.com

链接:https://github.com/hakluke/weaponised-XSS-payloads/blob/master/wordpress_create_admin_user.js

来源:wordpress.com

链接:http://wordpress.com/

来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/WordPress-wp-code-highlightjs-Cross-Site-Scripting-29845

来源:www.nsfocus.net

链接:http://www.nsfocus.net/vulndb/43837

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-12934

来源:www.securityfocus.com

链接:https://www.securityfocus.com/bid/109331

受影响实体

    暂无


补丁

    暂无

漏洞信息快速查询

相关漏洞

更多