漏洞信息详情

IDRIX Truecrypt和Veracrypt 缓冲区错误漏洞

  • CNNVD编号:CNNVD-201907-1262
  • 危害等级: 低危
  • CVE编号: CVE-2019-1010208
  • 漏洞类型: 缓冲区错误
  • 发布时间: 2019-07-23
  • 威胁类型: 本地
  • 更新时间: 2020-07-28
  • 厂        商:
  • 漏洞来源:

漏洞简介

Veracrypt是一款基于TrueCrypt的磁盘加密程序。

IDRIX Truecrypt和Veracrypt 1.23及之前版本中存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/veracrypt/VeraCrypt/commit/f30f9339c9a0b9bbcc6f5ad38804af39db1f479e

参考网址

来源:MISC

链接:https://github.com/veracrypt/VeraCrypt/commit/f30f9339c9a0b9bbcc6f5ad38804af39db1f479e

来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/Truecrypt-VeraCrypt-buffer-overflow-via-veracrypt-sys-29866

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多