漏洞信息详情

GPAC 缓冲区错误漏洞

  • CNNVD编号:CNNVD-201907-797
  • 危害等级: 高危
  • CVE编号: CVE-2019-13618
  • 漏洞类型: 缓冲区错误
  • 发布时间: 2019-07-16
  • 威胁类型: 远程
  • 更新时间: 2020-01-22
  • 厂        商:
  • 漏洞来源:

漏洞简介

GPAC是一款开源的多媒体框架。

GPAC 0.8.0之前版本中的libgpac.a静态链接库的isomedia/isom_read.c文件存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/gpac/gpac/issues/1250

参考网址

来源:MISC

链接:https://github.com/gpac/gpac/compare/440d475...6b4ab40

来源:github.com

链接:https://github.com/gpac/gpac/issues/1250

来源:MLIST

链接:https://lists.debian.org/debian-lts-announce/2020/01/msg00017.html

来源:lists.debian.org

链接:https://lists.debian.org/debian-lts-announce/2020/01/msg00017.html

来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/gpac-out-of-bounds-memory-reading-via-isomedia-isom-read-c-31373

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2020.0209/

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-13618

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多