漏洞信息详情

knot resolver DNS resolver 输入验证错误漏洞

  • CNNVD编号:CNNVD-201907-804
  • 危害等级: 高危
  • CVE编号: CVE-2019-10191
  • 漏洞类型: 输入验证错误
  • 发布时间: 2019-07-16
  • 威胁类型: 远程
  • 更新时间: 2019-07-25
  • 厂        商:
  • 漏洞来源:

漏洞简介

Knot Resolver是一款使用C语言和LuaJIT编写的开源缓存DNS解析器。DNS resolver是其中的一个DNS解析器组件。

knot resolver 4.1.0之前版本中的DNS resolver存在输入验证错误漏洞。该漏洞源于网络系统或产品未对输入的数据进行正确的验证。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://www.knot-resolver.cz/2019-07-10-knot-resolver-4.1.0.html

参考网址

来源:CONFIRM

链接:https://www.knot-resolver.cz/2019-07-10-knot-resolver-4.1.0.html

来源:CONFIRM

链接:https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10191

来源:FEDORA

链接:https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/TMSSWBHINIX4WE6UDXWM66L7JYEK6XS6/

来源:FEDORA

链接:https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VZV5YZZ5766UIG2TFLFJL6EESQNAP5X5/

来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/Knot-Resolver-privilege-escalation-via-DNSSEC-Downgrade-29826

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-10191

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多