漏洞信息详情

GnuCOBOL 缓冲区错误漏洞

  • CNNVD编号:CNNVD-201908-093
  • 危害等级: 高危
  • CVE编号: CVE-2019-14486
  • 漏洞类型: 缓冲区错误
  • 发布时间: 2019-08-01
  • 威胁类型: 本地
  • 更新时间: 2019-08-14
  • 厂        商:
  • 漏洞来源:

漏洞简介

GnuCOBOL是一款COBOL语言编译器。

GnuCOBOL 2.2版本中的cobc/field.c文件的\'\'cb_evaluate_expr\'\'存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://open-cobol.sourceforge.io/

参考网址

来源:sourceforge.net

链接:https://sourceforge.net/p/open-cobol/bugs/582/

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-14486

受影响实体

    暂无


补丁

    暂无

漏洞信息快速查询

相关漏洞

更多