漏洞信息详情

GNU Libextractor 缓冲区错误漏洞

  • CNNVD编号:CNNVD-201908-1916
  • 危害等级: 中危
  • CVE编号: CVE-2019-15531
  • 漏洞类型: 缓冲区错误
  • 发布时间: 2019-08-23
  • 威胁类型: 远程
  • 更新时间: 2019-09-03
  • 厂        商:
  • 漏洞来源:

漏洞简介

GNU Libextractor是GNU计划的一套用于从文件中提取元数据的库。

GNU Libextractor 1.9及之前版本中的plugins/dvi_extractor.c文件的‘EXTRACTOR_dvi_extract_method’函数存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://www.gnu.org/software/libextractor/

参考网址

来源:MISC

链接:https://bugs.gnunet.org/view.php?id=5846

来源:MLIST

链接:https://lists.debian.org/debian-lts-announce/2019/08/msg00038.html

来源:security-tracker.debian.org

链接:https://security-tracker.debian.org/tracker/DLA-1904-1

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2019.3307/

来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/GNU-Libextractor-out-of-bounds-memory-reading-via-EXTRACTOR-dvi-extract-method-30215

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-15531

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多