漏洞信息详情

WordPress pie-register插件SQL注入漏洞

  • CNNVD编号:CNNVD-201908-2060
  • 危害等级: 超危
  • CVE编号: CVE-2019-15659
  • 漏洞类型: SQL注入
  • 发布时间: 2019-08-27
  • 威胁类型: 远程
  • 更新时间: 2019-08-29
  • 厂        商:
  • 漏洞来源:

漏洞简介

WordPress是WordPress基金会的一套使用PHP语言开发的博客平台。该平台支持在PHP和MySQL的服务器上架设个人博客网站。pie-register是一款用户注册和登录表单自定义插件。

WordPress pie-register插件3.1.2之前版本中存在SQL注入漏洞。该漏洞源于基于数据库的应用缺少对外部输入SQL语句的验证。攻击者可利用该漏洞执行非法SQL命令。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://wordpress.org/plugins/pie-register/#developers

参考网址

来源:wpvulndb.com

链接:https://wpvulndb.com/vulnerabilities/9835

来源:wordpress.org

链接:https://wordpress.org/plugins/pie-register/#developers

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-15659

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多