漏洞信息详情

Bootstrap-3-Typeahead 跨站脚本漏洞

  • CNNVD编号:CNNVD-201910-295
  • 危害等级: 中危
  • CVE编号: CVE-2019-10215
  • 漏洞类型: 跨站脚本
  • 发布时间: 2019-10-02
  • 威胁类型: 远程
  • 更新时间: 2020-07-29
  • 厂        商:
  • 漏洞来源: Red Hat

漏洞简介

Bootstrap-3-Typeahead是一款自动文本填充插件。

Bootstrap-3-Typeahead 4.0.2之后版本中的‘highlighter()’函数存在跨站脚本漏洞。该漏洞源于WEB应用缺少对客户端数据的正确验证。攻击者可利用该漏洞执行客户端代码。

漏洞公告

目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://github.com/bassjobsen/Bootstrap-3-Typeahead

参考网址

来源:REDHAT

链接:https://access.redhat.com/errata/RHSA-2019:3771

来源:bugzilla.redhat.com

链接:https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10215

来源:SUSE

链接:http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00083.html

来源:access.redhat.com

链接:https://access.redhat.com/errata/RHSA-2019:3771

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2019.4276/

来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/155327/Red-Hat-Security-Advisory-2019-3771-01.html

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-10215

来源:access.redhat.com

链接:https://access.redhat.com/security/cve/cve-2019-10215

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2020.2492/

来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/Bootstrap-3-Typeahead-Cross-Site-Scripting-via-highlighter-32926

受影响实体

    暂无


补丁

    暂无

漏洞信息快速查询

相关漏洞

更多