漏洞信息详情

serialize-javascript 跨站脚本漏洞

  • CNNVD编号:CNNVD-201912-251
  • 危害等级: 中危
  • CVE编号: CVE-2019-16769
  • 漏洞类型: 跨站脚本
  • 发布时间: 2019-12-05
  • 威胁类型: 远程
  • 更新时间: 2020-10-29
  • 厂        商:
  • 漏洞来源: Red Hat

漏洞简介

serialize-javascript是一款支持将JavaScript序列化为 JSON超集的软件包。

serialize-javascript 2.1.1之前版本中存在跨站脚本漏洞。该漏洞源于WEB应用缺少对客户端数据的正确验证。攻击者可利用该漏洞执行客户端代码。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/yahoo/serialize-javascript/security/advisories/GHSA-h9rv-jmmf-4pgx

参考网址

来源:github.com

链接:https://github.com/yahoo/serialize-javascript/security/advisories/GHSA-h9rv-jmmf-4pgx

来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/158278/Red-Hat-Security-Advisory-2020-2796-01.html

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2020.3700/

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-16769

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2020.0922/

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2020.2283/

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多