漏洞信息详情

GNU LibreDWG 代码问题漏洞

  • CNNVD编号:CNNVD-202001-271
  • 危害等级: 中危
  • CVE编号: CVE-2020-6615
  • 漏洞类型: 代码问题
  • 发布时间: 2020-01-08
  • 威胁类型: 远程
  • 更新时间: 2022-09-13
  • 厂        商:
  • 漏洞来源:

漏洞简介

GNU LibreDWG是GNU计划的一个用于处理DWG文件的C语言库。

GNU LibreDWG 0.9.3.2564版本中的dynapi.c文件的‘dwg_dynapi_entity_value’函数存在代码问题漏洞。该漏洞源于网络系统或产品的代码开发过程中存在设计或实现不当的问题。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/LibreDWG/libredwg/commit/757b87f2d01127df1fa890f7a6c8608ffe9cd23e

参考网址

来源:MISC

链接:https://github.com/LibreDWG/libredwg/issues/179#issuecomment-570447223

来源:SUSE

链接:http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00046.html

来源:SUSE

链接:http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00052.html

来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/GNU-LibreDWG-seven-vulnerabilities-31443

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2020-6615

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多