漏洞信息详情

omniauth-weibo-oauth2 gem for Ruby 代码注入漏洞

  • CNNVD编号:CNNVD-202002-213
  • 危害等级: 超危
  • CVE编号: CVE-2019-17268
  • 漏洞类型: 代码注入
  • 发布时间: 2020-02-07
  • 威胁类型: 远程
  • 更新时间: 2020-02-12
  • 厂        商:
  • 漏洞来源:

漏洞简介

omniauth-weibo-oauth2 gem for Ruby是一款基于Ruby的身份验证软件包。

omniauth-weibo-oauth2 gem for Ruby 0.4.6版本(部署在RubyGems.org上)中存在安全漏洞。攻击者可利用该漏洞执行代码。

漏洞公告

目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://github.com/beenhero/omniauth-weibo-oauth2

参考网址

来源:diff.coditsu.io

链接:https://diff.coditsu.io/diffs/09a05c37-1b34-49e1-ac94-d4dda40d1ad1#d2h-971595

来源:github.com

链接:https://github.com/beenhero/omniauth-weibo-oauth2/issues/36

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-17268

受影响实体

    暂无


补丁

    暂无

漏洞信息快速查询

相关漏洞

更多