漏洞信息详情

Libnsbmp 缓冲区错误漏洞

  • CNNVD编号:CNNVD-202002-745
  • 危害等级: 高危
  • CVE编号: CVE-2015-7508
  • 漏洞类型: 缓冲区错误
  • 发布时间: 2020-02-12
  • 威胁类型: 远程
  • 更新时间: 2020-05-18
  • 厂        商:
  • 漏洞来源:

漏洞简介

Libnsbmp是一款使用C语言编写的、用于BMP和ICO图像文件格式的解码库。

Libnsbmp 0.1.2版本的libnsbmp.c文件的‘bmp_decode_rle’函数存在缓冲区错误漏洞。攻击者可借助特制的BMP文件中最后一行的RLE数据利用该漏洞导致拒绝服务或执行任意代码。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

http://source.netsurf-browser.org/libnsbmp.git/commit/?id=041df43bbe273b0829132b0b17d89a69da2927d4

参考网址

来源:MISC

链接:http://seclists.org/fulldisclosure/2015/Dec/73

来源:MISC

链接:http://www.securityfocus.com/archive/1/archive/1/537132/100/0/threaded

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多