漏洞信息详情

多款WSO2产品代码问题漏洞

  • CNNVD编号:CNNVD-202005-316
  • 危害等级: 高危
  • CVE编号: CVE-2020-12719
  • 漏洞类型: 代码问题
  • 发布时间: 2020-05-07
  • 威胁类型: 远程
  • 更新时间: 2020-05-22
  • 厂        商:
  • 漏洞来源:

漏洞简介

WSO2 API Manager等都是美国WSO2公司的产品。WSO2 API Manager是一套API生命周期管理解决方案。WSO2 Identity Server(IS)是一款身份认证服务器。WSO2 Enterprise Integrator是一套开源的混合集成平台。

多款WSO2产品中存在安全漏洞。攻击者可利用该漏洞获取本地文件,造成拒绝服务,伪造服务器端请求,扫描端口或造成其他危害。以下产品及版本受到影响:WSO2 API Manager 3.0.0及之前版本;WSO2 API Manager Analytics 2.5.0及之前版本;WSO2 API Microgateway 2.2.0版本;WSO2 Enterprise Integrator 6.4.0及之前版本;WSO2 IS as Key Manager 5.9.0及之前版本;WSO2 Identity Server 5.9.0及之前版本;WSO2 Identity Server Analytics 5.6.0及之前版本。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://docs.wso2.com/display/Security/Security+Advisory+WSO2-2019-0665

参考网址

来源:MISC

链接:https://docs.wso2.com/display/Security/Security+Advisory+WSO2-2019-0665

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2020-12719

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多