漏洞信息详情

Sanitize 跨站脚本漏洞

  • CNNVD编号:CNNVD-202006-1129
  • 危害等级: 高危
  • CVE编号: CVE-2020-4054
  • 漏洞类型: 跨站脚本
  • 发布时间: 2020-06-16
  • 威胁类型: 远程
  • 更新时间: 2020-09-29
  • 厂        商:
  • 漏洞来源: Ubuntu

漏洞简介

Sanitize是美国Ryan Grove软件开发者的一款HTML和CSS清理器,它支持从字符串中删除HTML和CSS等。

Sanitize 3.0.0及之后版本(5.2.1版本已修复)中存在跨站脚本漏洞。攻击者可借助特制输入利用该漏洞注入任意的HTML或造成其他危害。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/rgrove/sanitize/releases/tag/v5.2.1

参考网址

来源:CONFIRM

链接:https://github.com/rgrove/sanitize/security/advisories/GHSA-p4x4-rw2p-8j8m

来源:UBUNTU

链接:https://usn.ubuntu.com/4543-1/

来源:MISC

链接:https://github.com/rgrove/sanitize/releases/tag/v5.2.1

来源:MISC

链接:https://github.com/rgrove/sanitize/commit/a11498de9e283cd457b35ee252983662f7452aa9

来源:DEBIAN

链接:https://www.debian.org/security/2020/dsa-4730

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2020-4054

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2020.2450/

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2020.3310/

来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/RubyGem-Sanitize-Cross-Site-Scripting-via-Relaxed-Config-32870

来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/159296/Ubuntu-Security-Notice-USN-4543-1.html

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多