漏洞信息详情

mruby 缓冲区错误漏洞

  • CNNVD编号:CNNVD-202007-1360
  • 危害等级: 超危
  • CVE编号: CVE-2020-15866
  • 漏洞类型: 缓冲区错误
  • 发布时间: 2020-07-21
  • 威胁类型: 远程
  • 更新时间: 2022-05-09
  • 厂        商:
  • 漏洞来源:

漏洞简介

mruby是一款Ruby语言的轻量级实现。

mruby 2.1.2-rc及之前版本中的vm.c文件的‘mrb_yield_with_class’函数存在缓冲区错误漏洞,该漏洞源于程序没有正确检查边界。远程攻击者可借助‘stack_copy’函数利用该漏洞在系统上执行任意代码。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/mruby/mruby/commit/6334949ba69363cb909a57d6871895bd6d98bb6b

参考网址

来源:MLIST

链接:https://lists.debian.org/debian-lts-announce/2022/05/msg00006.html

来源:MISC

链接:https://github.com/mruby/mruby/issues/5042

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2020-15866

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2022.2170

来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/mruby-buffer-overflow-via-mrb-yield-with-class-38270

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多