漏洞信息详情

Lua 缓冲区错误漏洞

  • CNNVD编号:CNNVD-202007-1361
  • 危害等级: 超危
  • CVE编号: CVE-2020-15889
  • 漏洞类型: 缓冲区错误
  • 发布时间: 2020-07-21
  • 威胁类型: 远程
  • 更新时间: 2020-12-24
  • 厂        商:
  • 漏洞来源:

漏洞简介

Lua是Lua(LUA)团队的一款轻量级、扩展的开源脚本语言。

Lua 5.4.0及之前版本中存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/lua/lua/commit/127e7a6c8942b362aa3c6627f44d660a4fb75312

参考网址

来源:MISC

链接:https://github.com/lua/lua/commit/127e7a6c8942b362aa3c6627f44d660a4fb75312

来源:MISC

链接:http://lua-users.org/lists/lua-l/2020-12/msg00157.html

来源:MISC

链接:http://lua-users.org/lists/lua-l/2020-07/msg00078.html

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2020-15889

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多