漏洞信息详情

Auth0 node-auth0 安全漏洞

  • CNNVD编号:CNNVD-202007-1706
  • 危害等级: 高危
  • CVE编号: CVE-2020-15125
  • 漏洞类型: 其他
  • 发布时间: 2020-07-29
  • 威胁类型: 远程
  • 更新时间: 2020-08-04
  • 厂        商:
  • 漏洞来源:

漏洞简介

Auth0 node-auth0是美国Auth0公司的一款Auth0平台的Node.js客户端库。

Auth0 node-auth0 2.27.1之前版本中存在安全漏洞,该漏洞源于程序没有清除Authorization标头的密钥。攻击者可利用该漏洞泄露令牌信息。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/auth0/node-auth0/security/advisories/GHSA-5jpf-pj32-xx53

参考网址

来源:CONFIRM

链接:https://github.com/auth0/node-auth0/security/advisories/GHSA-5jpf-pj32-xx53

来源:MISC

链接:https://github.com/auth0/node-auth0/pull/507

来源:MISC

链接:https://github.com/auth0/node-auth0/tree/v2.27.1

来源:MISC

链接:https://github.com/auth0/node-auth0/pull/507/commits/62ca61b3348ec8e74d7d00358661af1a8bc98a3c

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2020-15125

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多