漏洞信息详情

Faye 信任管理问题漏洞

  • CNNVD编号:CNNVD-202007-1892
  • 危害等级: 高危
  • CVE编号: CVE-2020-15134
  • 漏洞类型: 信任管理问题
  • 发布时间: 2020-07-31
  • 威胁类型: 远程
  • 更新时间: 2020-08-12
  • 厂        商:
  • 漏洞来源:

漏洞简介

Faye是James Coglan软件开发者的一套开源的基于Bayeux协议的发布-订阅消息系统。该系统主要用于在Web客户端之间进行发布-订阅消息传递。

Faye 1.4.0之前版本中存信任管理问题漏洞,该漏洞源于在TLS握手过程中,程序没有进行证书检查。攻击者可利用该漏洞实施中间人攻击。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/faye/faye/security/advisories/GHSA-3q49-h8f9-9fr9

参考网址

来源:CONFIRM

链接:https://github.com/faye/faye/security/advisories/GHSA-3q49-h8f9-9fr9

来源:MISC

链接:https://blog.jcoglan.com/2020/07/31/missing-tls-verification-in-faye/

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2020-15134

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多