漏洞信息详情

TimelineJS 跨站脚本漏洞

  • CNNVD编号:CNNVD-202007-436
  • 危害等级: 中危
  • CVE编号: CVE-2020-15092
  • 漏洞类型: 跨站脚本
  • 发布时间: 2020-07-09
  • 威胁类型: 远程
  • 更新时间: 2020-07-30
  • 厂        商:
  • 漏洞来源:

漏洞简介

TimelineJS是美国西北大学骑士实验室(Northwestern University Knight Lab)的一款用于构建交互式时间轴的开源工具。

TimelineJS 3.7.0之前版本中存在跨站脚本漏洞,该漏洞源于程序没有正确验证用户输入。远程攻击者可利用该漏洞获取用户的身份验证凭据。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/NUKnightLab/TimelineJS3/security/advisories/GHSA-2jpm-827p-j44g

参考网址

来源:MISC

链接:https://knightlab.northwestern.edu/posts/

来源:CONFIRM

链接:https://github.com/NUKnightLab/TimelineJS3/security/advisories/GHSA-2jpm-827p-j44g

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2020-15092

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多